NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2017-11480 — beats

HIGHFix: elastic/beats#5457

CVE-2017-11480 is a high-severity (CVSS 7.5) CWE-404 vulnerability in github.com/elastic/beats. A fix is available for github.com/elastic/beats — see the affected versions and patch details below.

Denial of Service in Packetbeat

Also known asGHSA-9q3g-m353-cp4pGO-2022-0643
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.04%0.67%1.30%1.94%0.5%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/elastic/beats🐹github.com/elastic/beats

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Packetbeat versions prior to 5.6.4 and 6.0.0 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/elastic/beatsall versions5.6.4go get github.com/elastic/beats@v5.6.4
🐹Gogithub.com/elastic/beats≥ 6.0.0-alpha1&&< 6.0.06.0.0go get github.com/elastic/beats@v6.0.0

Affected Products

1 product · 1 configurations
Application
packetbeatelasticsearch
< 5.6.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/elastic/beats, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/elastic/beats to 5.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-11480 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Packetbeat versions prior to 5.6.4 and 6.0.0 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
O3 Security · Impact-Aware SCA

Is CVE-2017-11480 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2017-11480: beats DoS — Fixed in 5.6.4