NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2017-10843 — basercms

HIGH

CVE-2017-10843 is a high-severity (CVSS 7.5) vulnerability in baserproject/basercms. A fix is available for baserproject/basercms — see the affected versions and patch details below.

Arbitrary file delete in baserCMS

Also known asGHSA-x73x-7gmx-w835
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.07%0.69%1.30%1.92%0.6%1.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘baserproject/basercms🐘baserproject/basercms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

baserCMS version 3.0.14 and earlier, 4.0.5 and earlier allows remote attackers to delete arbitrary files via unspecified vectors when the "File" field is being used in the mail form.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbaserproject/basercmsall versions3.0.15composer require baserproject/basercms:^3.0.15
🐘Packagistbaserproject/basercms≥ 4.0.0&&< 4.0.64.0.6composer require baserproject/basercms:^4.0.6

Affected Products

1 product · 2 configurations
Application
basercmsbasercms
≥ 4.0.0 && ≤ 4.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for baserproject/basercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update baserproject/basercms to 3.0.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-10843 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

baserCMS version 3.0.14 and earlier, 4.0.5 and earlier allows remote attackers to delete arbitrary files via unspecified vectors when the "File" field is being used in the mail form.
O3 Security · Impact-Aware SCA

Is CVE-2017-10843 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-10843: basercms — Fixed in 3.0.15