NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-1000495 — cms

MEDIUMFix: quickapps/cms@7d648f2

CVE-2017-1000495 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in quickapps/cms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for quickapps/cms — see the affected versions and patch details below.

QuickApps CMS Cross-site Scripting

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.38%0.75%1.13%0.2%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘quickapps/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

QuickApps CMS version 2.0.0 is vulnerable to Stored Cross-site Scripting in the user's real name field resulting in denial of service and performing unauthorised actions with an administrator user's account

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistquickapps/cmsall versions2.0.0composer require quickapps/cms:^2.0.0

Affected Products

1 product · 1 configurations
Application
quickapps cmsquickappscms
1 version
2.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for quickapps/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update quickapps/cms to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000495 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

QuickApps CMS version 2.0.0 is vulnerable to Stored Cross-site Scripting in the user's real name field resulting in denial of service and performing unauthorised actions with an administrator user's account
O3 Security · Impact-Aware SCA

Is CVE-2017-1000495 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-1000495: cms XSS — Fixed in 2.0.0