NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-1000402 — swarm-client

MEDIUM

CVE-2017-1000402 is a medium-severity (CVSS 5.9) Improper Input Validation vulnerability in org.jenkins-ci.plugins:swarm-client. A fix is available for org.jenkins-ci.plugins:swarm-client — see the affected versions and patch details below.

Jenkins Swarm Plugin Client vulnerable to man-in-the-middle attacks

Also known asGHSA-pj45-8vhc-mh2f
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.33%0.66%1.00%0.0%0.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.plugins:swarm-client☕org.jvnet.hudson.plugins:swarm-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:swarm-clientall versions3.5org.jenkins-ci.plugins:swarm-client:3.5
☕Mavenorg.jvnet.hudson.plugins:swarm-pluginall versionsNo fix

Affected Products

1 product · 1 configurations
Application
swarmjenkins
≤ 3.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:swarm-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:swarm-client to 3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000402 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000402 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-1000402: swarm-client — Fixed in 3.5