CVE-2017-1000026 is a high-severity (CVSS 7.5) Path Traversal vulnerability in mixlib-archive. A fix is available for mixlib-archive — see the affected versions and patch details below.
mixlib-archive Path Traversal vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mixlib-archiveReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Chef Software's mixlib-archive versions 0.3.0 and older are vulnerable to a directory traversal attack allowing attackers to overwrite arbitrary files by using ".." in tar archive entries
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | mixlib-archive | all versions | 0.4.0bundle update mixlib-archive --conservative |
Affected Products
mixlib-archiveprogressDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mixlib-archive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mixlib-archive to 0.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000026 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2017-1000026 in your dependencies?
Find it across RubyGems, including transitive dependencies.