CVE-2016-9589 — wildfly-undertow
HIGHCVE-2016-9589 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.wildfly:wildfly-undertow. A fix is available for org.wildfly:wildfly-undertow — see the affected versions and patch details below.
Red Hat Wildfly DoS
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.wildfly:wildfly-undertowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Undertow in Red Hat wildfly before version 11.0.0.Beta1 is vulnerable to a resource exhaustion resulting in a denial of service. Undertow keeps a cache of seen HTTP headers in persistent connections. It was found that this cache can easily exploited to fill memory with garbage, up to "max-headers" (default 200) * "max-header-size" (default 1MB) per active TCP connection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.wildfly:wildfly-undertow | all versions | 11.0.0.Beta1org.wildfly:wildfly-undertow:11.0.0.Beta1 |
Affected Products
jboss wildfly application serverredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly:wildfly-undertow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.wildfly:wildfly-undertow to 11.0.0.Beta1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9589 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss EAP 7.0 | see advisory | RHSA-2017:0830 |
| Red Hat JBoss EAP 7.1 | see advisory | RHSA-2017:3456 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-activemq-artemis-0:1.1.0-16.SP19_redhat_1.1.ep7.el6 | RHSA-2017:0831 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-jboss-ec2-eap-0:7.0.5-1.GA_redhat_1.ep7.el6 | RHSA-2017:0834 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 7 | eap7-activemq-artemis-0:1.1.0-16.SP19_redhat_1.1.ep7.el7 | RHSA-2017:0832 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-activemq-artemis-0:1.5.5.008-1.redhat_1.1.ep7.el6 | RHSA-2017:3454 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-jboss-ec2-eap-0:7.1.0-5.GA_redhat_5.ep7.el6 | RHSA-2017:3458 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 7 | eap7-activemq-artemis-0:1.5.5.008-1.redhat_1.1.ep7.el7 | RHSA-2017:3455 |
Frequently Asked Questions
Is CVE-2016-9589 in your dependencies?
Find it across Maven, including transitive dependencies.