CVE-2016-4993 is a medium-severity (CVSS 6.1) CWE-93 vulnerability in org.wildfly:wildfly-undertow. A fix is available for org.wildfly:wildfly-undertow — see the affected versions and patch details below.
Improper Neutralization of CRLF Sequences in Wildfly Undertow
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.wildfly:wildfly-undertowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
CRLF injection vulnerability in the Undertow web server in WildFly 10.0.0, as used in Red Hat JBoss Enterprise Application Platform (EAP) 7.x before 7.0.2, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.wildfly:wildfly-undertow | ≥ 10.0.0.Final&&< 11.0.0.Final | 11.0.0.Finalorg.wildfly:wildfly-undertow:11.0.0.Final |
Affected Products
jboss enterprise application platformredhatjboss wildfly application serverredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly:wildfly-undertow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.wildfly:wildfly-undertow to 11.0.0.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4993 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss EAP 7.0 | see advisory | RHSA-2016:1841 |
| Red Hat JBoss EAP 7.1 | see advisory | RHSA-2017:3456 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-activemq-artemis-0:1.1.0-15.SP18_redhat_1.1.ep7.el6 | RHSA-2016:1838 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-jboss-ec2-eap-0:7.0.2-2.GA_redhat_1.ep7.el6 | RHSA-2016:1840 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 7 | eap7-activemq-artemis-0:1.1.0-15.SP18_redhat_1.1.ep7.el7 | RHSA-2016:1839 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-activemq-artemis-0:1.5.5.008-1.redhat_1.1.ep7.el6 | RHSA-2017:3454 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-jboss-ec2-eap-0:7.1.0-5.GA_redhat_5.ep7.el6 | RHSA-2017:3458 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 7 | eap7-activemq-artemis-0:1.5.5.008-1.redhat_1.1.ep7.el7 | RHSA-2017:3455 |
Frequently Asked Questions
Is CVE-2016-4993 in your dependencies?
Find it across Maven, including transitive dependencies.