CVE-2016-9451 — core
MEDIUMCVE-2016-9451 is a medium-severity (CVSS 6.8) Open Redirect vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal Open Redirect
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Confirmation forms in Drupal 7.x before 7.52 make it easier for remote authenticated users to conduct open redirect attacks via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 7.0&&< 7.52 | 7.52composer require drupal/core:^7.52 |
| 🐘Packagist | drupal/core | ≥ 8.0&&< 8.2.3 | 8.2.3composer require drupal/core:^8.2.3 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 7.52 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9451 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is CVE-2016-9451 in your dependencies?
Find it across Packagist, including transitive dependencies.