CVE-2016-9450 — core
HIGHCVE-2016-9450 is a high-severity (CVSS 7.5) CWE-345 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal Incorrect cache context on password reset page
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The user password reset form in Drupal 8.x before 8.2.3 allows remote attackers to conduct cache poisoning attacks by leveraging failure to specify a correct cache context.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.0&&< 8.2.3 | 8.2.3composer require drupal/core:^8.2.3 |
| 🐘Packagist | drupal/drupal | ≥ 8.0&&< 8.2.3 | 8.2.3composer require drupal/drupal:^8.2.3 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9450 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2016-9450 in your dependencies?
Find it across Packagist, including transitive dependencies.