CVE-2016-9449 — core
MEDIUMCVE-2016-9449 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal sensitive information disclosure
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The taxonomy module in Drupal 7.x before 7.52 and 8.x before 8.2.3 might allow remote authenticated users to obtain sensitive information about taxonomy terms by leveraging inconsistent naming of access query tags.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 7.0&&< 7.52 | 7.52composer require drupal/core:^7.52 |
| 🐘Packagist | drupal/core | ≥ 8.0&&< 8.2.3 | 8.2.3composer require drupal/core:^8.2.3 |
| 🐘Packagist | drupal/drupal | ≥ 8.0&&< 8.2.3 | 8.2.3composer require drupal/drupal:^8.2.3 |
| 🐘Packagist | drupal/drupal | ≥ 7.0&&< 7.52 | 7.52composer require drupal/drupal:^7.52 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 7.52 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9449 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2016-9449 in your dependencies?
Find it across Packagist, including transitive dependencies.