NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2016-8737 — brooklyn-rest-resources

HIGHFix: apache/brooklyn-server#430

CVE-2016-8737 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in org.apache.brooklyn:brooklyn-rest-resources. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.brooklyn:brooklyn-rest-resources — see the affected versions and patch details below.

Apache Brooklyn is vulnerable to cross-site request forgery (CSRF)

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.21%1.82%0.2%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.brooklyn:brooklyn-rest-resources☕org.apache.brooklyn:brooklyn-jsgui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site request forgery (CSRF), which could permit a malicious web site to produce a link which, if clicked whilst a user is logged in to Brooklyn, would cause the server to execute the attacker's commands as the user. There is known to be a proof-of-concept exploit using this vulnerability.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.brooklyn:brooklyn-rest-resourcesall versions0.10.0org.apache.brooklyn:brooklyn-rest-resources:0.10.0
☕Mavenorg.apache.brooklyn:brooklyn-jsguiall versions0.10.0org.apache.brooklyn:brooklyn-jsgui:0.10.0

Affected Products

1 product · 1 configurations
Application
brooklynapache
≤ 0.9.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.brooklyn:brooklyn-rest-resources, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.brooklyn:brooklyn-rest-resources to 0.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-8737 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site request forgery (CSRF), which could permit a malicious web site to produce a link which, if clicked whilst a user is logged in to Brooklyn, would cause the server to execute the attacker's commands as the user. There is known to be a proof-of-concept exploit using this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2016-8737 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-8737: brooklyn-rest CSRF — Fixed in 0.10.0