NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2016-6795 — struts2-convention-plugin

CRITICALFix: apache/struts@8e67b91

CVE-2016-6795 is a critical-severity (CVSS 9.8) Path Traversal vulnerability in org.apache.struts:struts2-convention-plugin. A fix is available for org.apache.struts:struts2-convention-plugin — see the affected versions and patch details below.

Path Traversal in Apache Struts

Also known asGHSA-44hv-jjx7-qfjg
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
3.62%5.60%7.57%9.55%5.0%8.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.struts:struts2-convention-plugin☕org.apache.struts:struts2-convention-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Struts 2.3.x before 2.3.31, and 2.5.x before 2.5.5, it is possible to prepare a special URL which will be used for path traversal and execution of arbitrary code on server side. This vulnerability is only exploitable when using the Struts 2 Convention plugin in conjunction with Apache Struts.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.struts:struts2-convention-plugin≥ 2.3.0&&< 2.3.312.3.31org.apache.struts:struts2-convention-plugin:2.3.31
☕Mavenorg.apache.struts:struts2-convention-plugin≥ 2.5.0&&< 2.5.52.5.5org.apache.struts:struts2-convention-plugin:2.5.5

Affected Products

1 product · 18 configurations
Application
strutsapache
18 versions
2.3.202.3.20.12.3.20.22.3.20.32.3.212.3.222.3.232.3.242.3.24.12.3.24.22.3.24.32.3.25

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-convention-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.struts:struts2-convention-plugin to 2.3.31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6795 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

In Apache Struts 2.3.x before 2.3.31, and 2.5.x before 2.5.5, it is possible to prepare a special URL which will be used for path traversal and execution of arbitrary code on server side. This vulnerability is only exploitable when using the Struts 2 Convention plugin in conjunction with Apache Struts.
O3 Security · Impact-Aware SCA

Is CVE-2016-6795 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-6795: struts2-convention RCE — Fixed in 2.3.31