CVE-2016-6212 — core
MEDIUMCVE-2016-6212 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal Views can allow unauthorized users to see Statistics information
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The Views module 7.x-3.x before 7.x-3.14 in Drupal 7.x and the Views module in Drupal 8.x before 8.1.3 might allow remote authenticated users to bypass intended access restrictions and obtain sensitive Statistics information via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.0&&< 8.1.3 | 8.1.3composer require drupal/core:^8.1.3 |
| 🐘Packagist | drupal/drupal | ≥ 8.0&&< 8.1.3 | 8.1.3composer require drupal/drupal:^8.1.3 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6212 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2016-6212 in your dependencies?
Find it across Packagist, including transitive dependencies.