NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2016-6211 — core

HIGH

CVE-2016-6211 is a high-severity (CVSS 8.8) CWE-264 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Drupal Saving user accounts can sometimes grant the user all roles

Also known asGHSA-frqf-9qr4-6vxf
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.62%1.53%2.44%3.35%1.1%2.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘drupal/core🐘drupal/drupal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The User module in Drupal 7.x before 7.44 allows remote authenticated users to gain privileges via vectors involving contributed or custom code that triggers a rebuild of the user profile form.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 7.0&&< 7.447.44composer require drupal/core:^7.44
🐘Packagistdrupal/drupal≥ 7.0&&< 7.447.44composer require drupal/drupal:^7.44

Affected Products

2 products · 61 configurations
OS
debian linuxdebian
1 version
8.0
Application
drupaldrupal
45 versions
7.07.17.27.37.47.57.67.77.87.97.107.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 7.44 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6211 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The User module in Drupal 7.x before 7.44 allows remote authenticated users to gain privileges via vectors involving contributed or custom code that triggers a rebuild of the user profile form.
O3 Security · Impact-Aware SCA

Is CVE-2016-6211 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-6211: core — Fixed in 7.44