NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-5394 — org.apache.sling.xss

MEDIUMFix: apache/sling-org-apache-sling-xss@de32b14

CVE-2016-5394 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.sling:org.apache.sling.xss. A fix is available for org.apache.sling:org.apache.sling.xss — see the affected versions and patch details below.

Cross site scripting in Apache Sling

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.59%1.43%2.27%3.10%1.1%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.sling:org.apache.sling.xss☕org.apache.sling:org.apache.sling.xss.compat

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In the XSS Protection API module before 1.0.12 in Apache Sling, the encoding done by the XSSAPI.encodeForJSString() method is not restrictive enough and for some input patterns allows script tags to pass through unencoded, leading to potential XSS vulnerabilities.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.sling:org.apache.sling.xssall versions1.0.12org.apache.sling:org.apache.sling.xss:1.0.12
☕Mavenorg.apache.sling:org.apache.sling.xss.compatall versions1.1.0org.apache.sling:org.apache.sling.xss.compat:1.1.0

Affected Products

1 product · 1 configurations
Application
slingapache
< 1.0.12
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.sling:org.apache.sling.xss, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.sling:org.apache.sling.xss to 1.0.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-5394 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In the XSS Protection API module before 1.0.12 in Apache Sling, the encoding done by the XSSAPI.encodeForJSString() method is not restrictive enough and for some input patterns allows script tags to pass through unencoded, leading to potential XSS vulnerabilities.
O3 Security · Impact-Aware SCA

Is CVE-2016-5394 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-5394: org.apache.sling.xss XSS — Fixed in 1.0.12