NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2016-4972 — murano

CRITICALFix: openstack/murano@28de8c3

CVE-2016-4972 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in murano. A fix is available for murano — see the affected versions and patch details below.

OpenStack Murano Code Execution

Also known asGHSA-87r7-q54j-f9qgPYSEC-2016-22PYSEC-2026-429PYSEC-2026-430
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
2.67%3.25%3.84%4.43%3.9%3.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐍murano🐍murano-dashboard🐍murano-dashboard🐍python-muranoclient🐍python-muranoclient

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Murano before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), Murano-dashboard before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), and python-muranoclient before 0.7.3 (liberty) and 0.8.x before 0.8.5 (mitaka) improperly use loaders inherited from yaml.Loader when parsing MuranoPL and UI files, which allows remote attackers to create arbitrary Python objects and execute arbitrary code via crafted extended YAML tags in UI definitions in packages.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImuranoall versions1.0.3pip install --upgrade 'murano==1.0.3'
🐍PyPImurano-dashboardall versions1.0.3pip install --upgrade 'murano-dashboard==1.0.3'
🐍PyPImurano-dashboard≥ 2.0.0&&< 2.0.12.0.1pip install --upgrade 'murano-dashboard==2.0.1'
🐍PyPIpython-muranoclientall versions0.7.3pip install --upgrade 'python-muranoclient==0.7.3'
🐍PyPIpython-muranoclient≥ 0.8.0&&< 0.8.50.8.5pip install --upgrade 'python-muranoclient==0.8.5'

Affected Products

4 products · 4 configurations
Application
mitaka-muranoopenstack
≤ 2.0.0
range
Application
muranoopenstack
≤ 1.0.2
range
Application
murano-dashboardopenstack
≤ 1.0.2
range
Application
python-muranoclientopenstack
≤ 0.7.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for murano, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update murano to 1.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4972 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

OpenStack Murano before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), Murano-dashboard before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), and python-muranoclient before 0.7.3 (liberty) and 0.8.x before 0.8.5 (mitaka) improperly use loaders inherited from yaml.Loader when parsing MuranoPL and UI files, which allows remote attackers to create arbitrary Python objects and execute arbitrary code via crafted extended YAML tags in UI definitions in packages.
O3 Security · Impact-Aware SCA

Is CVE-2016-4972 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-4972: murano RCE — Fixed in 1.0.3