NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2016-3166 — core

MEDIUM

CVE-2016-3166 is a medium-severity (CVSS 5.9) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Drupal CRLF injection vulnerability in the drupal_set_header function

Also known asGHSA-fg5q-r2q5-qmh3
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.56%1.12%1.68%0.5%1.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘drupal/core🐘drupal/drupal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CRLF injection vulnerability in the drupal_set_header function in Drupal 6.x before 6.38, when used with PHP before 5.1.2, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks by leveraging a module that allows user-submitted data to appear in HTTP headers.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 6.0&&< 6.386.38composer require drupal/core:^6.38
🐘Packagistdrupal/drupal≥ 6.0&&< 6.386.38composer require drupal/drupal:^6.38

Affected Products

2 products · 49 configurations
OS
debian linuxdebian
2 versions
7.08.0
Application
drupaldrupal
38 versions
6.06.16.26.36.46.56.66.76.86.96.106.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 6.38 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3166 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

CRLF injection vulnerability in the drupal_set_header function in Drupal 6.x before 6.38, when used with PHP before 5.1.2, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks by leveraging a module that allows user-submitted data to appear in HTTP headers.
O3 Security · Impact-Aware SCA

Is CVE-2016-3166 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-3166: core — Fixed in 6.38