NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2016-3163 — core

HIGH

CVE-2016-3163 is a high-severity (CVSS 7.5) CWE-254 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Drupal Brute force amplification attacks via XML-RPC

Also known asGHSA-h3r9-pjmr-f938
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.36%0.88%1.40%1.93%0.9%1.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The XML-RPC system in Drupal 6.x before 6.38 and 7.x before 7.43 might make it easier for remote attackers to conduct brute-force attacks via a large number of calls made at once to the same method.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 7.0&&< 7.437.43composer require drupal/core:^7.43
🐘Packagistdrupal/core≥ 6.0&&< 6.386.38composer require drupal/core:^6.38
🐘Packagistdrupal/drupal≥ 7.0&&< 7.437.43composer require drupal/drupal:^7.43
🐘Packagistdrupal/drupal≥ 6.0&&< 6.386.38composer require drupal/drupal:^6.38

Affected Products

2 products · 106 configurations
OS
debian linuxdebian
2 versions
7.08.0
Application
drupaldrupal
80 versions
6.06.16.26.36.46.56.66.76.86.106.116.12

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 7.43 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3163 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The XML-RPC system in Drupal 6.x before 6.38 and 7.x before 7.43 might make it easier for remote attackers to conduct brute-force attacks via a large number of calls made at once to the same method.
O3 Security · Impact-Aware SCA

Is CVE-2016-3163 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-3163: core — Fixed in 7.43