CVE-2016-2162 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.struts:struts2-core. A fix is available for org.apache.struts:struts2-core — see the affected versions and patch details below.
Apache Struts XSS Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.struts:struts2-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Struts 2.x before 2.3.25 does not sanitize text in the Locale object constructed by I18NInterceptor, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors involving language display.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.struts:struts2-core | ≥ 2.0.0&&< 2.3.28 | 2.3.28org.apache.struts:struts2-core:2.3.28 |
Affected Products
strutsapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.struts:struts2-core to 2.3.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2162 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2016-2162 in your dependencies?
Find it across Maven, including transitive dependencies.