CVE-2016-10074 — swiftmailer
CRITICALCVE-2016-10074 is a critical-severity (CVSS 9.8) CWE-77 vulnerability in swiftmailer/swiftmailer. 7 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for swiftmailer/swiftmailer — see the affected versions and patch details below.
Swift Mailer mail transport Command Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
swiftmailer/swiftmailerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The mail transport (aka Swift_Transport_MailTransport) in Swift Mailer before 5.4.5 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a " (backslash double quote) in a crafted e-mail address in the (1) From, (2) ReturnPath, or (3) Sender header.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | swiftmailer/swiftmailer | all versions | 5.4.5composer require swiftmailer/swiftmailer:^5.4.5 |
Affected Products
swiftmailerswiftmailerResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
PHPMailer < 5.2.20 with Exim MTA - Remote Code Execution
by phackt_ul · Jun 21, 2017
PHPMailer < 5.2.20 / SwiftMailer < 5.4.5-DEV / Zend Framework / zend-mail < 2.4.11 - 'AIO' 'PwnScriptum' Remote Code Execution
by Dawid Golunski · Jan 2, 2017
SwiftMailer < 5.4.5-DEV - Remote Code Execution
by Dawid Golunski · Dec 28, 2016
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swiftmailer/swiftmailer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update swiftmailer/swiftmailer to 5.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-10074 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2016-10074 in your dependencies?
Find it across Packagist, including transitive dependencies.