CVE-2016-10034 — zend-mail
CRITICALCVE-2016-10034 is a critical-severity (CVSS 9.8) CWE-77 vulnerability in zendframework/zend-mail. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for zendframework/zend-mail — see the affected versions and patch details below.
zend-mail remote code execution via Sendmail adapter
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zendframework/zend-mail🐘zendframework/zend-mail🐘zendframework/zend-mail🐘zendframework/zend-mailReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11, 2.5.x, 2.6.x, and 2.7.x before 2.7.2, and Zend Framework before 2.4.11 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a " (backslash double quote) in a crafted e-mail address.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zend-mail | all versions | 2.4.11composer require zendframework/zend-mail:^2.4.11 |
| 🐘Packagist | zendframework/zend-mail | ≥ 2.5 | No fix |
| 🐘Packagist | zendframework/zend-mail | ≥ 2.6 | No fix |
| 🐘Packagist | zendframework/zend-mail | ≥ 2.7&&< 2.7.2 | 2.7.2composer require zendframework/zend-mail:^2.7.2 |
Affected Products
zend frameworkzendzend-mailzendResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
PHPMailer < 5.2.20 with Exim MTA - Remote Code Execution
by phackt_ul · Jun 21, 2017
PHPMailer < 5.2.20 / SwiftMailer < 5.4.5-DEV / Zend Framework / zend-mail < 2.4.11 - 'AIO' 'PwnScriptum' Remote Code Execution
by Dawid Golunski · Jan 2, 2017
Zend Framework / zend-mail < 2.4.11 - Remote Code Execution
by Dawid Golunski · Dec 30, 2016
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zend-mail, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zend-mail to 2.4.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-10034 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2016-10034 in your dependencies?
Find it across Packagist, including transitive dependencies.