NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-0784 — openmeetings-install

MEDIUMFix: apache/openmeetings@fbab889

CVE-2016-0784 is a medium-severity (CVSS 6.5) Path Traversal vulnerability in org.apache.openmeetings:openmeetings-install. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.openmeetings:openmeetings-install — see the affected versions and patch details below.

Apache OpenMeetings Directory Traversal vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
54.7%probability of exploitation in next 30 days
High Risk-1.66%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%23.8%47.6%71.4%6.1%54.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.openmeetings:openmeetings-install

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Directory traversal vulnerability in the Import/Export System Backups functionality in Apache OpenMeetings before 3.1.1 allows remote authenticated administrators to write to arbitrary files via a .. (dot dot) in a ZIP archive entry.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.openmeetings:openmeetings-install≥ 1.9.0&&< 3.1.13.1.1org.apache.openmeetings:openmeetings-install:3.1.1

Affected Products

1 product · 1 configurations
Application
openmeetingsapache
≤ 3.1.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-39642webappslinux

Apache OpenMeetings 1.9.x < 3.1.0 - '.ZIP' File Directory Traversal

by Andreas Lindh · Mar 31, 2016

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.openmeetings:openmeetings-install, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.openmeetings:openmeetings-install to 3.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0784 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Directory traversal vulnerability in the Import/Export System Backups functionality in Apache OpenMeetings before 3.1.1 allows remote authenticated administrators to write to arbitrary files via a .. (dot dot) in a ZIP archive entry.
O3 Security · Impact-Aware SCA

Is CVE-2016-0784 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-0784: openmeetings — Fixed in 3.1.1