NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-0767 — pljava-public

MEDIUM

CVE-2016-0767 is a medium-severity (CVSS 6.5) Improper Privilege Management vulnerability in postgresql:pljava-public. A fix is available for postgresql:pljava-public — see the affected versions and patch details below.

PostgreSQL PL/Java Improper Privilege Management

Also known asGHSA-837x-xww6-7jqm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.96%1.43%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕postgresql:pljava-public

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenpostgresql:pljava-publicall versions1.5.0postgresql:pljava-public:1.5.0

Affected Products

1 product · 1 configurations
Application
pl\/javapl\/java_project
≤ 1.4.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for postgresql:pljava-public, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update postgresql:pljava-public to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0767 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.
O3 Security · Impact-Aware SCA

Is CVE-2016-0767 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-0767: pljava-public — Fixed in 1.5.0