NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-0712 — jetspeed

MEDIUM

CVE-2016-0712 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.portals.jetspeed-2:jetspeed. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.portals.jetspeed-2:jetspeed — see the affected versions and patch details below.

Cross-site Scripting in Apache Jetspeed

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
2.05%2.60%3.15%3.70%2.6%3.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.portals.jetspeed-2:jetspeed

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Apache Jetspeed before 2.3.1 allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to portal.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.portals.jetspeed-2:jetspeedall versions2.3.1org.apache.portals.jetspeed-2:jetspeed:2.3.1

Affected Products

1 product · 1 configurations
Application
jetspeedapache
≤ 2.3.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.portals.jetspeed-2:jetspeed, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.portals.jetspeed-2:jetspeed to 2.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0712 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Apache Jetspeed before 2.3.1 allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to portal.
O3 Security · Impact-Aware SCA

Is CVE-2016-0712 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-0712: jetspeed XSS — Fixed in 2.3.1