NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2016-0710 — jetspeed

HIGH

CVE-2016-0710 is a high-severity (CVSS 8.8) SQL Injection vulnerability in org.apache.portals.jetspeed-2:jetspeed. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.portals.jetspeed-2:jetspeed — see the affected versions and patch details below.

Apache Jetspeed vulnerable to SQL Injection

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
5 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
52.4%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
44.3%58.6%73.0%87.3%79.2%52.4%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.portals.jetspeed-2:jetspeed

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed before 2.3.1 allow remote attackers to execute arbitrary SQL commands via the (1) role or (2) user parameter to services/usermanager/users/.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.portals.jetspeed-2:jetspeedall versions2.3.1org.apache.portals.jetspeed-2:jetspeed:2.3.1

Affected Products

1 product · 1 configurations
Application
jetspeedapache
≤ 2.3.0
range
Exploits & PoCs
5

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-39643remotejava✓ Verified

Apache Jetspeed - Arbitrary File Upload (Metasploit)

by Metasploit · Mar 31, 2016

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.portals.jetspeed-2:jetspeed, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.portals.jetspeed-2:jetspeed to 2.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0710 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed before 2.3.1 allow remote attackers to execute arbitrary SQL commands via the (1) role or (2) user parameter to services/usermanager/users/.
O3 Security · Impact-Aware SCA

Is CVE-2016-0710 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-0710: jetspeed SQL Injection — Fixed in 2.3.1