NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2015-8814 — Umbraco.CMS

HIGHFix: umbraco/Umbraco-CMS@18c3345

CVE-2015-8814 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in Umbraco.CMS. A fix is available for Umbraco.CMS — see the affected versions and patch details below.

Umbraco CMS vulnerable to CSRF

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.38%0.75%1.13%0.1%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
.NETUmbraco.CMS

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Umbraco before 7.4.0 allows remote attackers to bypass anti-forgery security measures and conduct cross-site request forgery (CSRF) attacks as demonstrated by editing user account information in the templates.asmx.cs file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetUmbraco.CMSall versions7.4.0dotnet add package Umbraco.CMS --version 7.4.0

Affected Products

1 product · 1 configurations
Application
umbracoumbraco
1 version
7.3.8

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Umbraco.CMS, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Umbraco.CMS to 7.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8814 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Umbraco before 7.4.0 allows remote attackers to bypass anti-forgery security measures and conduct cross-site request forgery (CSRF) attacks as demonstrated by editing user account information in the `templates.asmx.cs` file.
O3 Security · Impact-Aware SCA

Is CVE-2015-8814 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2015-8814: Umbraco.CMS CSRF — Fixed in 7.4.0