NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2015-8813 — Umbraco.CMS

HIGHFix: umbraco/Umbraco-CMS@924a016

CVE-2015-8813 is a high-severity (CVSS 8.2) Server-Side Request Forgery (SSRF) vulnerability in Umbraco.CMS. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for Umbraco.CMS — see the affected versions and patch details below.

Umbraco CMS vulnerable to CSRF

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
11.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%82.8%11.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
.NETUmbraco.CMS

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

The Page_Load function in Umbraco.Web/umbraco.presentation/umbraco/dashboard/FeedProxy.aspx.cs in Umbraco before 7.4.0 allows remote attackers to conduct server-side request forgery (SSRF) attacks via the url parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetUmbraco.CMSall versions7.4.0dotnet add package Umbraco.CMS --version 7.4.0

Affected Products

1 product · 1 configurations
Application
umbracoumbraco
≤ 7.3.8
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Umbraco.CMS, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Umbraco.CMS to 7.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8813 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

How to detect CVE-2015-8813

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2015-8813 -u https://target
Template
Umbraco <7.4.0- Server-Side Request Forgery
Severity
high
Impact
The vulnerability can result in unauthorized access to sensitive information or systems, leading to potential data breaches or further exploitation.
Remediation
Upgrade Umbraco to version 7.4.0 or above to mitigate the vulnerability and apply any necessary patches or security updates.

Template by ProjectDiscovery nuclei-templates (emadshanab), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

The `Page_Load` function in [Umbraco.Web/umbraco.presentation/umbraco/dashboard/FeedProxy.aspx.cs](https://github.com/umbraco/Umbraco-CMS/commit/924a016ffe7ae7ea6d516c07a7852f0095eddbce#diff-2899f01df84571577834f97a81637c65e20178ec6129b76c02f99789b23cf72e) in Umbraco before 7.4.0 allows remote attackers to conduct server-side request forgery (SSRF) attacks via the url parameter.
O3 Security · Impact-Aware SCA

Is CVE-2015-8813 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2015-8813: Umbraco.CMS SSRF — Fixed in 7.4.0