NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2015-8766 — symphony-2

MEDIUMFix: symphonycms/symphony-2@651e150

CVE-2015-8766 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in symphonycms/symphony-2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for symphonycms/symphony-2 — see the affected versions and patch details below.

Symphony CMS XSS Vulnerabilities

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.76%1.51%2.27%0.3%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘symphonycms/symphony-2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in content/content.systempreferences.php in Symphony CMS before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via the (1) email_sendmail[from_name], (2) email_sendmail[from_address], (3) email_smtp[from_name], (4) email_smtp[from_address], (5) email_smtp[host], (6) email_smtp[port], (7) jit_image_manipulation[trusted_external_sites], or (8) maintenance_mode[ip_whitelist] parameters to system/preferences.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymphonycms/symphony-2all versions2.6.4composer require symphonycms/symphony-2:^2.6.4

Affected Products

1 product · 1 configurations
Application
symphonygetsymphony
≤ 2.6.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symphonycms/symphony-2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symphonycms/symphony-2 to 2.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8766 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in `content/content.systempreferences.php` in Symphony CMS before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via the (1) `email_sendmail[from_name]`, (2) `email_sendmail[from_address]`, (3) `email_smtp[from_name]`, (4) `email_smtp[from_address]`, (5) `email_smtp[host]`, (6) `email_smtp[port]`, (7) `jit_image_manipulation[trusted_external_sites]`, or (8) `maintenance_mode[ip_whitelist]` parameters to system/preferences.
O3 Security · Impact-Aware SCA

Is CVE-2015-8766 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2015-8766: symphony-2 XSS — Fixed in 2.6.4