CVE-2015-8124 is a low-severity (CVSS 3.1) vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Symfony Session Fixation Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/security-http🐘symfony/security-http🐘symfony/security🐘symfony/security🐘symfony/securityReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A session fixation vulnerability within the "Remember Me" login feature allows an attacker to impersonate the victim towards the web application if the session id value was previously known to the attacker. This issue has been fixed in Symfony 2.3.35, 2.6.12, and 2.7.7. Note that no fixes are provided for Symfony 2.4 and 2.5 as they are not maintained anymore. Symfony 2.8 and 3.0 haven't been released yet and the fix will be included in their first stable releases.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.3.0&&< 2.3.35 | 2.3.35composer require symfony/symfony:^2.3.35 |
| 🐘Packagist | symfony/symfony | ≥ 2.4.0&&< 2.6.12 | 2.6.12composer require symfony/symfony:^2.6.12 |
| 🐘Packagist | symfony/symfony | ≥ 2.7.0&&< 2.7.7 | 2.7.7composer require symfony/symfony:^2.7.7 |
| 🐘Packagist | symfony/security-http | ≥ 2.4.0&&< 2.6.12 | 2.6.12composer require symfony/security-http:^2.6.12 |
| 🐘Packagist | symfony/security-http | ≥ 2.7.0&&< 2.7.7 | 2.7.7composer require symfony/security-http:^2.7.7 |
| 🐘Packagist | symfony/security | ≥ 2.3.0&&< 2.3.35 | 2.3.35composer require symfony/security:^2.3.35 |
Affected Products
symfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.3.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8124 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2015-8124 in your dependencies?
Find it across Packagist, including transitive dependencies.