CVE-2015-7529 — sosreport
HIGHCVE-2015-7529 is a high-severity (CVSS 7.8) CWE-59 vulnerability in sosreport. A fix is available for sosreport — see the affected versions and patch details below.
SoSReport Predictable Tmp File Names
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sosreportReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
sosreport in SoS 3.x allows local users to obtain sensitive information from sosreport files or gain privileges via a symlink attack on an archive file in a temporary directory, as demonstrated by sosreport-$hostname-$date.tar in /tmp/sosreport-$hostname-$date.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | sosreport | ≥ 3.0&&< 3.3 | 3.3pip install --upgrade 'sosreport==3.3' |
Affected Products
ubuntu linuxcanonicalenterprise linux desktopredhatenterprise linux serverredhatenterprise linux server ausredhatenterprise linux server eusredhatenterprise linux server tusredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sosreport, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sosreport to 3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7529 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | sos-0:3.2-28.el6_7.2 | RHSA-2016:0152 |
| Red Hat Enterprise Linux 7 | sos-0:3.2-35.el7_2.3 | RHSA-2016:0188 |
Frequently Asked Questions
Is CVE-2015-7529 in your dependencies?
Find it across PyPI, including transitive dependencies.