CVE-2015-3171 is a medium-severity (CVSS 5.5) Information Exposure vulnerability in sosreport. A fix is available for sosreport — see the affected versions and patch details below.
sosreport sensitive information disclosure via weak permissions of the generated archives
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sosreportReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
sosreport 3.2 uses weak permissions for generated sosreport archives, which allows local users with access to /var/tmp/ to obtain sensitive information by reading the contents of the archive.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | sosreport | all versions | 3.3pip install --upgrade 'sosreport==3.3' |
Affected Products
sossos_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sosreport, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sosreport to 3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3171 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2015-3171 in your dependencies?
Find it across PyPI, including transitive dependencies.