CVE-2015-1561 is a high-severity (CVSS 8.5) CWE-77 vulnerability in centreon/centreon. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for centreon/centreon — see the affected versions and patch details below.
Centreon Command Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
centreon/centreonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The escape_command function in include/Administration/corePerformance/getStats.php in Centreon (formerly Merethis Centreon) 2.5.4 and earlier (offending file deleted in Centreon 19.10.0) uses an incorrect regular expression, which allows remote authenticated users to execute arbitrary commands via shell metacharacters in the ns_id parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | centreon/centreon | all versions | 2.8.28composer require centreon/centreon:^2.8.28 |
Affected Products
centreoncentreonResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Centreon 2.5.4 - Multiple Vulnerabilities
by Huy-Ngoc DAU · Jul 8, 2015
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for centreon/centreon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update centreon/centreon to 2.8.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-1561 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2015-1561 in your dependencies?
Find it across Packagist, including transitive dependencies.