NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2014-4301 — ajenti

MEDIUMFix: Eugeny/ajenti@d3fc5eb

CVE-2014-4301 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ajenti. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for ajenti — see the affected versions and patch details below.

Eugene Pankov Ajenti Cross-site scripting Vulnerabilities

Also known asPYSEC-2014-99
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.96%1.92%2.88%0.4%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ajenti

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in the respond_error function in routing.py in Eugene Pankov Ajenti before 1.2.21.7 allow remote attackers to inject arbitrary web script or HTML via the PATH_INFO to (1) resources.js or (2) resources.css in ajenti:static/, related to the traceback page.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIajentiall versions1.2.21.7pip install --upgrade 'ajenti==1.2.21.7'

Affected Products

1 product · 22 configurations
Application
ajentiajenti
≤ 1.2.21
21 versions
1.2.01.2.11.2.21.2.31.2.41.2.51.2.61.2.71.2.81.2.91.2.101.2.11.2
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ajenti, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ajenti to 1.2.21.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-4301 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in the `respond_error` function in `routing.py` in Eugene Pankov Ajenti before 1.2.21.7 allow remote attackers to inject arbitrary web script or HTML via the `PATH_INFO` to (1) `resources.js` or (2) resources.css in `ajenti:static/`, related to the traceback page.
O3 Security · Impact-Aware SCA

Is CVE-2014-4301 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2014-4301: ajenti XSS — Fixed in 1.2.21.7