CVE-2014-2260 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in ajenti. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for ajenti — see the affected versions and patch details below.
Ajenti Cross-site scripting (XSS) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ajentiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in plugins/main/content/js/ajenti.coffee in Eugene Pankov Ajenti 1.2.13 allows remote authenticated users to inject arbitrary web script or HTML via the command field in the Cron functionality.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ajenti | all versions | 1.2.15pip install --upgrade 'ajenti==1.2.15' |
Affected Products
ajentiajentiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ajenti, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ajenti to 1.2.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-2260 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2014-2260 in your dependencies?
Find it across PyPI, including transitive dependencies.