NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2014-3943 — cms

CVE-2014-3943 is a Cross-site Scripting (XSS) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

Typo3 XSS Vulnerabilities

Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.65%1.30%1.95%0.2%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

5 pkgs affected
🐘typo3/cms🐘typo3/cms🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, 6.1.0 before 6.1.9, and 6.2.0 before 6.2.3 allow remote authenticated editors to inject arbitrary web script or HTML via unknown parameters.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 4.5.0&&< 4.5.344.5.34composer require typo3/cms:^4.5.34
🐘Packagisttypo3/cms≥ 4.7.0&&< 4.7.194.7.19composer require typo3/cms:^4.7.19
🐘Packagisttypo3/cms≥ 6.0.0&&< 6.0.146.0.14composer require typo3/cms:^6.0.14
🐘Packagisttypo3/cms≥ 6.1.0&&< 6.1.96.1.9composer require typo3/cms:^6.1.9
🐘Packagisttypo3/cms≥ 6.2.0&&< 6.2.36.2.3composer require typo3/cms:^6.2.3

Affected Products

1 product · 82 configurations
Application
typo3typo3
80 versions
4.5.04.5.14.5.24.5.34.5.44.5.54.5.64.5.74.5.84.5.94.5.104.5.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 4.5.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3943 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, 6.1.0 before 6.1.9, and 6.2.0 before 6.2.3 allow remote authenticated editors to inject arbitrary web script or HTML via unknown parameters.
O3 Security · Impact-Aware SCA

Is CVE-2014-3943 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2014-3943: cms XSS — Fixed in 4.5.34