NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2014-3942 — cms

CVE-2014-3942 is a Code Injection vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

TYPO3 Color Picker Wizard component allows remote authenticated editors to execute arbitrary PHP code

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.71%1.42%2.13%0.4%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘typo3/cms🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Color Picker Wizard component in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, and 6.1.0 before 6.1.9 allows remote authenticated editors to execute arbitrary PHP code via a serialized PHP object.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 4.5.0&&< 4.5.344.5.34composer require typo3/cms:^4.5.34
🐘Packagisttypo3/cms≥ 4.7.0&&< 4.7.194.7.19composer require typo3/cms:^4.7.19
🐘Packagisttypo3/cms≥ 6.0.0&&< 6.0.146.0.14composer require typo3/cms:^6.0.14
🐘Packagisttypo3/cms≥ 6.1.0&&< 6.1.96.1.9composer require typo3/cms:^6.1.9

Affected Products

1 product · 76 configurations
Application
typo3typo3
76 versions
4.5.04.5.14.5.24.5.34.5.44.5.54.5.64.5.74.5.84.5.94.5.104.5.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 4.5.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3942 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The Color Picker Wizard component in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, and 6.1.0 before 6.1.9 allows remote authenticated editors to execute arbitrary PHP code via a serialized PHP object.
O3 Security · Impact-Aware SCA

Is CVE-2014-3942 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2014-3942: cms — Fixed in 4.5.34