NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-3679 — monitoring

Fix: jenkinsci/monitoring-plugin@f0f6aee

CVE-2014-3679 is a security vulnerability in org.jvnet.hudson.plugins:monitoring. A fix is available for org.jvnet.hudson.plugins:monitoring — see the affected versions and patch details below.

Jenkins Monitoring Plugin Reveals Sensitive Information via Unspecified Pages

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.76%1.52%2.28%0.2%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.jvnet.hudson.plugins:monitoring

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to obtain sensitive information by accessing unspecified pages.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jvnet.hudson.plugins:monitoringall versions1.53.0org.jvnet.hudson.plugins:monitoring:1.53.0

Affected Products

1 product · 14 configurations
Application
monitoring pluginjenkins-ci
≤ 1.52.1
13 versions
1.40.01.41.01.42.01.43.01.44.01.45.01.46.01.47.01.48.01.49.01.50.01.51.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jvnet.hudson.plugins:monitoring, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jvnet.hudson.plugins:monitoring to 1.53.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3679 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to obtain sensitive information by accessing unspecified pages.
O3 Security · Impact-Aware SCA

Is CVE-2014-3679 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-3679: monitoring — Fixed in 1.53.0