NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-3678 — monitoring

Fix: jenkinsci/monitoring-plugin@f0f6aee

CVE-2014-3678 is a Cross-site Scripting (XSS) vulnerability in org.jvnet.hudson.plugins:monitoring. A fix is available for org.jvnet.hudson.plugins:monitoring — see the affected versions and patch details below.

Jenkins Monitoring Plugin allows Cross-Site Scripting (XSS)

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.78%1.56%2.34%0.3%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.jvnet.hudson.plugins:monitoring

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jvnet.hudson.plugins:monitoringall versions1.53.0org.jvnet.hudson.plugins:monitoring:1.53.0

Affected Products

1 product · 14 configurations
Application
monitoring pluginjenkins-ci
≤ 1.52.1
13 versions
1.40.01.41.01.42.01.43.01.44.01.45.01.46.01.47.01.48.01.49.01.50.01.51.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jvnet.hudson.plugins:monitoring, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jvnet.hudson.plugins:monitoring to 1.53.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3678 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Enterprise 2.1jenkins-0:1.565.3-1.el6opRHBA-2014:1630

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2014-3678 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-3678: monitoring XSS — Fixed in 1.53.0