CVE-2014-3627 — hadoop-client
CVE-2014-3627 is a CWE-59 vulnerability in org.apache.hadoop:hadoop-client. A fix is available for org.apache.hadoop:hadoop-client — see the affected versions and patch details below.
Improper Link Resolution Before File Access in Apache Hadoop
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.hadoop:hadoop-client☕org.apache.hadoop:hadoop-clientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The YARN NodeManager daemon in Apache Hadoop 0.23.0 through 0.23.11 and 2.x before 2.5.2, when using Kerberos authentication, allows remote cluster users to change the permissions of certain files to world-readable via a symlink attack in a public tar archive, which is not properly handled during localization, related to distributed cache.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hadoop:hadoop-client | ≥ 0.23.0&&< 1.0.1 | 1.0.1org.apache.hadoop:hadoop-client:1.0.1 |
| ☕Maven | org.apache.hadoop:hadoop-client | ≥ 2.0.0&&< 2.5.2 | 2.5.2org.apache.hadoop:hadoop-client:2.5.2 |
Affected Products
hadoopapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hadoop:hadoop-client to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3627 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2014-3627 in your dependencies?
Find it across Maven, including transitive dependencies.