CVE-2012-4449 — hadoop-client
CRITICALCVE-2012-4449 is a critical-severity (CVSS 9.8) Broken Cryptographic Algorithm vulnerability in org.apache.hadoop:hadoop-client. A fix is available for org.apache.hadoop:hadoop-client — see the affected versions and patch details below.
Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hadoop:hadoop-client☕org.apache.hadoop:hadoop-client☕org.apache.hadoop:hadoop-clientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Hadoop before 0.23.4, 1.x before 1.0.4, and 2.x before 2.0.2 generate token passwords using a 20-bit secret when Kerberos security features are enabled, which makes it easier for context-dependent attackers to crack secret keys via a brute-force attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hadoop:hadoop-client | all versions | 0.23.4org.apache.hadoop:hadoop-client:0.23.4 |
| ☕Maven | org.apache.hadoop:hadoop-client | ≥ 1.0.0&&< 1.0.4 | 1.0.4org.apache.hadoop:hadoop-client:1.0.4 |
| ☕Maven | org.apache.hadoop:hadoop-client | ≥ 2.0.0&&< 2.0.2 | 2.0.2org.apache.hadoop:hadoop-client:2.0.2 |
Affected Products
hadoopapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hadoop:hadoop-client to 0.23.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-4449 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2012-4449 in your dependencies?
Find it across Maven, including transitive dependencies.