Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven
CISA KEV · ACTIVELY EXPLOITED
HIGH severity

CVE-2014-3120 — elasticsearch

HIGHFix: elastic/elasticsearch#7642

CVE-2014-3120 is a high-severity (CVSS 8.1) CWE-284 vulnerability in org.elasticsearch:elasticsearch. It is in CISA's Known Exploited Vulnerabilities catalog (added 2022-03-25) — treat it as actively exploited and patch now. A fix is available for org.elasticsearch:elasticsearch — see the affected versions and patch details below.

Elasticsearch Improper Access Control vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
11 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, CISA KEV, FIRST.org (EPSS)

Exploitation Status

Actively exploited in the wild

  • Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2022-03-25. Federal agencies were required to remediate by 2022-04-15.

Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2014-3120.

EPSS Exploitation Probability

via FIRST.org ↗
88.6%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
80.8%84.0%87.2%90.3%82.6%88.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2014-3120 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 395,308 CVEs with a current EPSS score, this one falls in the 50–90% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

1 pkg affected
☕org.elasticsearch:elasticsearch

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The default configuration in Elasticsearch before 1.4.0.Beta1 enables dynamic scripting, which allows remote attackers to execute arbitrary MVEL expressions and Java code via the source parameter to _search. NOTE: this only violates the vendor's intended security policy if the user does not run Elasticsearch in its own independent virtual machine.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.elasticsearch:elasticsearchall versions1.4.0.Beta1org.elasticsearch:elasticsearch:1.4.0.Beta1

Affected Products

1 product · 1 configurations
Application
elasticsearchelastic
< 1.2.0
range
Exploits & PoCs
11

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-33588remotejava✓ Verified

ElasticSearch Dynamic Script - Arbitrary Java Execution (Metasploit)

by Metasploit · May 30, 2014

EDB-33370webappsmultiple✓ Verified

ElasticSearch - Remote Code Execution

by Jeff Geiger · May 15, 2014

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.elasticsearch:elasticsearch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.elasticsearch:elasticsearch to 1.4.0.Beta1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3120 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

How to detect CVE-2014-3120

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2014-3120 -u https://target
Template
ElasticSearch v1.1.1/1.2 RCE
Severity
medium
Impact
Allows remote attackers to execute arbitrary code on the affected system
Remediation
Upgrade to a patched version of ElasticSearch

Template by ProjectDiscovery nuclei-templates (pikpikcu), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

On Subscription Asset Manager (SAM) 1, the elasticsearch service is only bound to the loopback interface by default. To exploit this issue on a SAM 1 system, an attacker must have local access to the system. On Red Hat JBoss Fuse and Red Hat JBoss A-MQ, the elasticsearch service is only started if the…

ProductFixed inAdvisory
Fuse ESB Enterprise 7.1.0see advisoryRHSA-2014:1171
Red Hat JBoss A-MQ 6.1see advisoryRHSA-2014:1170
Red Hat Subscription Asset Manager 1.4katello-configure-0:1.4.5.1-3.el6samRHSA-2014:1186

Frequently Asked Questions

The default configuration in Elasticsearch before 1.4.0.Beta1 enables dynamic scripting, which allows remote attackers to execute arbitrary MVEL expressions and Java code via the source parameter to _search. NOTE: this only violates the vendor's intended security policy if the user does not run Elasticsearch in its own independent virtual machine.
O3 Security · Impact-Aware SCA

Is CVE-2014-3120 in your dependencies?

Find it across Maven, including transitive dependencies.

Actively Exploited: CVE-2014-3120: elasticsearch (High 8.1)