CVE-2014-125107 is a medium-severity (CVSS 4.3) CWE-693 vulnerability in corveda/phpsandbox. A fix is available for corveda/phpsandbox — see the affected versions and patch details below.
Corveda PHPSandbox Protection Mechanism Failure vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
corveda/phpsandboxReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in Corveda PHPSandbox 1.3.4 and classified as critical. Affected by this issue is some unknown functionality of the component String Handler. The manipulation leads to protection mechanism failure. The attack may be launched remotely. Upgrading to version 1.3.5 is able to address this issue. The patch is identified as 48fde5ffa4d76014bad260a3cbab7ada3744a4cc. It is recommended to upgrade the affected component. VDB-248270 is the identifier assigned to this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | corveda/phpsandbox | all versions | 1.3.5composer require corveda/phpsandbox:^1.3.5 |
Affected Products
phpsandboxcorvedaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for corveda/phpsandbox, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update corveda/phpsandbox to 1.3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-125107 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2014-125107 in your dependencies?
Find it across Packagist, including transitive dependencies.