NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2014-0161 — ovirt-engine-sdk-python

MEDIUM

CVE-2014-0161 is a medium-severity (CVSS 5.9) CWE-295 vulnerability in ovirt-engine-sdk-python. A fix is available for ovirt-engine-sdk-python — see the affected versions and patch details below.

ovirt-engine-sdk-python improper validation of hostname in x.509 certificate

Also known asPYSEC-2020-245
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs36th percentile — riskier than 36% of all scored CVEsHighest risk
0.00%0.31%0.61%0.92%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍ovirt-engine-sdk-python🐍ovirt-engine-sdk-python

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

ovirt-engine-sdk-python before 3.4.0.7 and 3.5.0.4 does not verify that the hostname of the remote endpoint matches the Common Name (CN) or subjectAltName as specified by its x.509 certificate in a TLS/SSL session. This could allow man-in-the-middle attackers to spoof remote endpoints via an arbitrary valid certificate.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIovirt-engine-sdk-pythonall versions3.4.0.7pip install --upgrade 'ovirt-engine-sdk-python==3.4.0.7'
🐍PyPIovirt-engine-sdk-python≥ 3.5.0.0&&< 3.5.0.43.5.0.4pip install --upgrade 'ovirt-engine-sdk-python==3.5.0.4'

Affected Products

1 product · 2 configurations
Application
ovirt-engine-sdk-pythonovirt-engine-sdk-python_project
≥ 3.5.0.0 && < 3.5.0.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ovirt-engine-sdk-python, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ovirt-engine-sdk-python to 3.4.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0161 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

ovirt-engine-sdk-python before 3.4.0.7 and 3.5.0.4 does not verify that the hostname of the remote endpoint matches the Common Name (CN) or subjectAltName as specified by its x.509 certificate in a TLS/SSL session. This could allow man-in-the-middle attackers to spoof remote endpoints via an arbitrary valid certificate.
O3 Security · Impact-Aware SCA

Is CVE-2014-0161 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2014-0161: ovirt-engine-sdk-python — Fixed in 3.4.0.7