CVE-2013-4752 — symfony
MEDIUMCVE-2013-4752 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Symfony Host Header Injection vulnerability in the HttpFoundation component
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/http-foundationReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Symfony 2.0.X before 2.0.24, 2.1.X before 2.1.12, 2.2.X before 2.2.5, and 2.3.X before 2.3.3 have an issue in the HttpFoundation component. The Host header can be manipulated by an attacker when the framework is generating an absolute URL. A remote attacker could exploit this vulnerability to inject malicious content into the Web application page and conduct various attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.0.0&&< 2.0.24 | 2.0.24composer require symfony/symfony:^2.0.24 |
| 🐘Packagist | symfony/symfony | ≥ 2.1.0&&< 2.1.12 | 2.1.12composer require symfony/symfony:^2.1.12 |
| 🐘Packagist | symfony/symfony | ≥ 2.2.0&&< 2.2.5 | 2.2.5composer require symfony/symfony:^2.2.5 |
| 🐘Packagist | symfony/symfony | ≥ 2.3.0&&< 2.3.3 | 2.3.3composer require symfony/symfony:^2.3.3 |
| 🐘Packagist | symfony/http-foundation | ≥ 2.0.0&&< 2.0.24 | 2.0.24composer require symfony/http-foundation:^2.0.24 |
| 🐘Packagist | symfony/http-foundation | ≥ 2.1.0&&< 2.1.12 | 2.1.12composer require symfony/http-foundation:^2.1.12 |
Affected Products
fedorafedoraprojectsymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.0.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4752 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2013-4752 in your dependencies?
Find it across Packagist, including transitive dependencies.