NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2013-4701 — php-openid

Fix: openid/php-openid@625c16b

CVE-2013-4701 is a security vulnerability in openid/php-openid. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for openid/php-openid — see the affected versions and patch details below.

PHP OpenID Library Denial of Service vulnerability

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.25%1.37%2.50%3.63%0.9%3.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘openid/php-openid🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistopenid/php-openidall versions2.3.0composer require openid/php-openid:^2.3.0
🐘Packagisttypo3/cms≥ 6.2.0&&< 6.2.66.2.6composer require typo3/cms:^6.2.6

Affected Products

1 product · 1 configurations
Application
php-openidjanrain
≤ 2.2.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openid/php-openid, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openid/php-openid to 2.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4701 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
O3 Security · Impact-Aware SCA

Is CVE-2013-4701 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2013-4701: php-openid DoS — Fixed in 2.3.0