NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET NuGet
Not in CISA KEV

CVE-2013-4649 — DotNetNuke.Core

CVE-2013-4649 is a Cross-site Scripting (XSS) vulnerability in DotNetNuke.Core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for DotNetNuke.Core — see the affected versions and patch details below.

DotNetNuke (DNN) Cross-site scripting (XSS) vulnerability via the __dnnVariable parameter

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%1.04%2.08%3.13%0.3%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
.NETDotNetNuke.Core.NETDotNetNuke.Core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 6.2.9 and 7.x before 7.1.1 allows remote attackers to inject arbitrary web script or HTML via the __dnnVariable parameter to the default URI.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetDotNetNuke.Coreall versions6.2.9dotnet add package DotNetNuke.Core --version 6.2.9
.NETNuGetDotNetNuke.Core≥ 7.0&&< 7.1.17.1.1dotnet add package DotNetNuke.Core --version 7.1.1

Affected Products

1 product · 65 configurations
Application
dotnetnukednnsoftware
≤ 6.2.8
64 versions
1.0.61.0.71.0.81.0.91.0.10d1.0.10e2.1.12.1.23.0.73.0.83.0.113.1.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for DotNetNuke.Core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update DotNetNuke.Core to 6.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4649 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 6.2.9 and 7.x before 7.1.1 allows remote attackers to inject arbitrary web script or HTML via the __dnnVariable parameter to the default URI.
O3 Security · Impact-Aware SCA

Is CVE-2013-4649 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2013-4649: DotNetNuke.Core XSS — Fixed in 6.2.9