NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2013-4409 — djblets

CRITICAL

CVE-2013-4409 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in djblets. A fix is available for djblets — see the affected versions and patch details below.

ReviewBoard and Djblets library are vulnerable to code execution

Also known asPYSEC-2019-175PYSEC-2026-524
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.42%1.75%3.07%4.39%1.2%3.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍djblets🐍djblets🐍reviewboard

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An eval() vulnerability exists in Python Software Foundation Djblets version before 0.6.30 and 0.7.0 before 0.7.19 and Beanbag Review Board before 1.7.15 when parsing JSON requests allowing an attacker to execute arbitrary Python code.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjbletsall versions0.6.30pip install --upgrade 'djblets==0.6.30'
🐍PyPIdjblets≥ 0.7.0&&< 0.7.190.7.19pip install --upgrade 'djblets==0.7.19'
🐍PyPIreviewboardall versions1.7.15pip install --upgrade 'reviewboard==1.7.15'

Affected Products

4 products · 6 configurations
OS
fedorafedoraproject
3 versions
181920
OS
enterprise linuxredhat
1 version
6.0
Application
djbletsreviewboard
1 version
0.7.21
Application
review boardreviewboard
< 1.7.15
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for djblets, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update djblets to 0.6.30 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4409 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An eval() vulnerability exists in Python Software Foundation Djblets version before 0.6.30 and 0.7.0 before 0.7.19 and Beanbag Review Board before 1.7.15 when parsing JSON requests allowing an attacker to execute arbitrary Python code.
O3 Security · Impact-Aware SCA

Is CVE-2013-4409 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2013-4409: djblets — Fixed in 0.6.30