CVE-2013-4111 — python-glanceclient
HIGHCVE-2013-4111 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in python-glanceclient. A fix is available for python-glanceclient — see the affected versions and patch details below.
python-glanceclient vulnerable to SSL server spoofing due to unverified X.509 certificate
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
python-glanceclientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The Python client library for Glance (python-glanceclient) before 0.10.0 does not properly check the preverify_ok value, which prevents the server hostname from being verified with a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate and allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | python-glanceclient | all versions | 0.10.0pip install --upgrade 'python-glanceclient==0.10.0' |
Affected Products
python glanceclientopenstackopensuseopensuseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-glanceclient, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update python-glanceclient to 0.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4111 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack 3 for RHEL 6 | python-glanceclient-1:0.9.0-2.el6ost | RHSA-2013:1200 |
Frequently Asked Questions
Is CVE-2013-4111 in your dependencies?
Find it across PyPI, including transitive dependencies.