NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2013-3300 — lift-webkit

Fix: lift/framework@099d9c8

CVE-2013-3300 is a Buffer Overflow vulnerability in net.liftweb:lift-webkit. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for net.liftweb:lift-webkit — see the affected versions and patch details below.

Lift Sensitive Information Disclosure

Published
Updated
Affected
8 pkgs
Patched
1 / 8
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.66%1.32%1.98%0.2%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

8 pkgs affected
☕net.liftweb:lift-webkit☕net.liftweb:lift-webkit_2.7.7☕net.liftweb:lift-webkit_2.8.0☕net.liftweb:lift-webkit_2.8.1☕net.liftweb:lift-webkit_2.8.2☕net.liftweb:lift-webkit_2.9.0☕net.liftweb:lift-webkit_2.9.0-1☕net.liftweb:lift-webkit_2.9.1

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The JsonParser class in json/JsonParser.scala in Lift before 2.5 interprets a certain end-index value as a length value, which allows remote authenticated users to obtain sensitive information from other users' sessions via invalid input data containing a < (less than) character.

Affected Packages

8 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavennet.liftweb:lift-webkitall versionsNo fix
☕Mavennet.liftweb:lift-webkit_2.7.7all versionsNo fix
☕Mavennet.liftweb:lift-webkit_2.8.0all versionsNo fix
☕Mavennet.liftweb:lift-webkit_2.8.1all versionsNo fix
☕Mavennet.liftweb:lift-webkit_2.8.2all versionsNo fix
☕Mavennet.liftweb:lift-webkit_2.9.0all versionsNo fix

Affected Products

1 product · 11 configurations
Application
liftliftweb
≤ 2.5
5 versions
2.12.22.32.42.5
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for net.liftweb:lift-webkit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2013-3300; check the affected-versions list above or the advisory for the patched release of net.liftweb:lift-webkit, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

The JsonParser class in json/JsonParser.scala in Lift before 2.5 interprets a certain end-index value as a length value, which allows remote authenticated users to obtain sensitive information from other users' sessions via invalid input data containing a < (less than) character.
O3 Security · Impact-Aware SCA

Is CVE-2013-3300 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2013-3300: lift-webkit Info Disclosure — Fixed in 2.5