NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2013-2633 — matomo

CVE-2013-2633 is a Improper Input Validation vulnerability in matomo/matomo. A fix is available for matomo/matomo — see the affected versions and patch details below.

Piwik (now Matomo) Reveals Sensitive Information by Accepting Input from `POST` Requests

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.00%1.49%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘matomo/matomo🐘piwik/piwik

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Piwik before 1.11 accepts input from a POST request instead of a GET request in unspecified circumstances, which might allow attackers to obtain sensitive information by leveraging the logging of parameters.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmatomo/matomoall versions1.11composer require matomo/matomo:^1.11
🐘Packagistpiwik/piwikall versions1.11composer require piwik/piwik:^1.11

Affected Products

1 product · 21 configurations
Application
matomomatomo
≤ 1.10.1
20 versions
1.01.11.1.11.21.2.11.31.41.51.5.11.61.71.7.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for matomo/matomo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update matomo/matomo to 1.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2633 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Piwik before 1.11 accepts input from a POST request instead of a GET request in unspecified circumstances, which might allow attackers to obtain sensitive information by leveraging the logging of parameters.
O3 Security · Impact-Aware SCA

Is CVE-2013-2633 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2013-2633: matomo Info Disclosure — Fixed in 1.11